Login    Forum    Search    FAQ

Board index » Upgrading and Repairing Forum » Laptop Hardware




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Not recognizing USB devices, mostly under Ubuntu partition
 Post Posted: Fri Jul 29, 2011 10:10 pm 
Offline

Joined: Sun Feb 07, 2010 2:47 pm
Posts: 94
Hi Scott,

I finally got through the 19th edition. I really feel I know a lot more than I did. Thanks. I can't wait for the 3rd edition of your laptop book to come out.

I've been having intermittent problems recognizing USB devices on my Ubuntu partition. Sometimes I have problems on my Win7 partition too, but mostly it's on my Ubuntu partition. I've read on some forums that you don't have to be concerned about mobo chipset drivers with Ubuntu. Anyway, no one's answered any of my posts:

http://ubuntuforums.org/showthread.php? ... st11092920

This is for my ThinkPad T40p. I'm not sure what information you might need. There's this utility called "sysinfo". It says my "host bridge" is:

Intel Corporation 82855PM Processor to I/O Controller (rev03)

and my "USB controller" is:

USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)

Also, I'm not sure if this is relevant, but when I type in "lsusb" at a command prompt I get:

Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Please let me know if I can supply you with any other information that might be helpful.


Top 
 Profile  
Reply with quote  
 Post subject: Re: Not recognizing USB devices, mostly under Ubuntu partiti
 Post Posted: Fri Jul 29, 2011 10:26 pm 
Offline
Site Admin

Joined: Sun Feb 04, 2007 11:44 am
Posts: 5734
The problem should be either hardware or software. If the problem occurs under Ubuntu but not under Windows, then it is most likely the Ubuntu OS and/or drivers that are at fault. Besides making sure your OS and drivers are up to date, I'd also make sure you are running the latest BIOS. You might also try a clean OS and driver install to see if corruption of the existing OS might be an issue.

If however, the problem occurs under both Ubuntu and Windows, then it may be the hardware that is at fault. Since that hardware would be the motherboard chipset, you could either replace the motherboard (not cost effective) or install a very inexpensive USB adapter card and disable or ignore the faulty motherboard based ports. Scott.


Top 
 Profile  
Reply with quote  
 Post subject: Re: Not recognizing USB devices, mostly under Ubuntu partiti
 Post Posted: Fri Aug 26, 2011 8:14 pm 
Offline

Joined: Sun Feb 07, 2010 2:47 pm
Posts: 94
Apparently, the drivers are all built into the kernel in linux, so that wasn't it.

I put in a CardBus USB 2.0 card and now it works just fine for only $13.00.

Thanks, Scott.


Top 
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 3 posts ] 

Board index » Upgrading and Repairing Forum » Laptop Hardware


Who is online

Users browsing this forum: No registered users and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron