[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4762: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4764: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4765: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4766: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
Scott Mueller's Upgrading and Repairing PCs Forum • View topic - Why does browsing a network share in Explorer take so long?
Login    Forum    Search    FAQ

Board index » Upgrading and Repairing Forum » Windows OS




Post new topic Reply to topic  [ 13 posts ] 
Author Message
 Post subject: Why does browsing a network share in Explorer take so long?
 Post Posted: Wed Mar 20, 2013 3:30 pm 
Offline

Joined: Wed Mar 18, 2009 12:48 pm
Posts: 405
Location: USA
In my office I am connected to a Domain and one of the mapped drives takes a very long time to list the directories in Explorer. I'd say around 10 seconds while any other mapped drive opens immediately.

Any ideas why this might happen? Particular services that need to enabled/disabled on my workstation? Anti-virus software on the server?

Just to throw some other observations, when I use to search the drive or any treemapping software there is no delay. FileLocator scans all servers on the network at the same rate. Also, if I remote into a terminal server then there is no delay.

Evan


Top 
 Profile  
Reply with quote  
 Post subject: Re: Why does browsing a network share in Explorer take so lo
 Post Posted: Wed Mar 20, 2013 4:20 pm 
Offline
Site Admin

Joined: Sun Feb 04, 2007 11:44 am
Posts: 6180


Top 
 Profile  
Reply with quote  
 Post subject: Re: Why does browsing a network share in Explorer take so lo
 Post Posted: Wed Mar 20, 2013 5:11 pm 
Offline

Joined: Wed Mar 18, 2009 12:48 pm
Posts: 405
Location: USA
I like those but I don't think they will help. I'll go ahead and enable them and let you know if I see a difference tomorrow.

If it is the server what suggestions do you have or what additional info do you need?

Evan


Top 
 Profile  
Reply with quote  
 Post subject: Re: Why does browsing a network share in Explorer take so lo
 Post Posted: Wed Mar 20, 2013 6:33 pm 
Offline
Site Admin

Joined: Sun Feb 04, 2007 11:44 am
Posts: 6180
I can't think of anything to check on the server end other than to see if or how it is configured any differently than the others. Scott.


Top 
 Profile  
Reply with quote  
 Post subject: Re: Why does browsing a network share in Explorer take so lo
 Post Posted: Wed Mar 20, 2013 8:31 pm 
Offline

Joined: Wed Mar 18, 2009 12:48 pm
Posts: 405
Location: USA
I'll let you know how the tweaks turn out and if/when I can check the server configuration I'll see how it's different.

Evan


Top 
 Profile  
Reply with quote  
 Post subject: Re: Why does browsing a network share in Explorer take so lo
 Post Posted: Thu Mar 21, 2013 10:40 am 
Offline

Joined: Wed Mar 18, 2009 12:48 pm
Posts: 405
Location: USA
I applied the tweaks and restarted the machine. Still no change. It takes about 20 seconds roughly. There is only one other share on that server and I can access it immediately.

Evan


Top 
 Profile  
Reply with quote  
 Post subject: Re: Why does browsing a network share in Explorer take so lo
 Post Posted: Thu Mar 21, 2013 12:11 pm 
Offline
Site Admin

Joined: Sun Feb 04, 2007 11:44 am
Posts: 6180
I just thought of this: I've seen delays of about that length when opening shares on servers configured to allow the drives to spin down. The delay happens when I first open the share from a remote system, and the delay is caused by waiting for the drive to spin up. Successive accesses have no delay, that is of course until after the drive spins down again. Check the power management settings on the server to insure that the drives remain active all the time. Scott.


Top 
 Profile  
Reply with quote  
 Post subject: Re: Why does browsing a network share in Explorer take so lo
 Post Posted: Thu Mar 21, 2013 12:28 pm 
Offline

Joined: Wed Mar 18, 2009 12:48 pm
Posts: 405
Location: USA
I'll check that and I'll see how other shares or folders respond from the same partition.

Any ideas on services that might affect this (like computer browser or branche cache)?

Evan


Top 
 Profile  
Reply with quote  
 Post subject: Re: Why does browsing a network share in Explorer take so lo
 Post Posted: Thu Mar 21, 2013 6:45 pm 
Offline
Site Admin

Joined: Sun Feb 04, 2007 11:44 am
Posts: 6180
Any services that would be used for one should also be used for another, so that wouldn't explain any delay. I would recommend using the Sysinternals tools as described and to see if you can find out exactly what is going on when the delay occurs. It will also allow you to compare the steps occurring during normal browsing to what happens with the slow one to see what is happening differently. Let me know what you find. Scott.


Top 
 Profile  
Reply with quote  
 Post subject: Re: Why does browsing a network share in Explorer take so lo
 Post Posted: Thu Mar 21, 2013 7:24 pm 
Offline

Joined: Wed Mar 18, 2009 12:48 pm
Posts: 405
Location: USA
Thank you for posting a link to . I had read that article when it was posted and I was trying to remember that info. I did a Process Monitor trace before I posted and found a gap but needed some guidance on how to dig into it. My guy reaction is some sort of Antivirus scan but I know there's more to it than that. If I figure anything out I'll let you know.

I tried one other change. I mapped a subfolder and it has a delay although it is much less. It's about 3 seconds vs 20 seconds. I think this points to scanning enumerated files but I don't understand why the Terminal Server has zero delay. Hopefully a Process Monitor scan of the new mapped drive will reveal something.

Evan


Top 
 Profile  
Reply with quote  
 Post subject: Re: Why does browsing a network share in Explorer take so lo
 Post Posted: Thu Mar 28, 2013 12:18 pm 
Offline

Joined: Wed Mar 18, 2009 12:48 pm
Posts: 405
Location: USA
I asked the boss that set it up and he said it was a caching issue on the server side. If you open up Explorer and expand the tree for the network share that expands without delay. If you simply double click the drive letter and let the folders populate the main window it takes forever.

Does that give you any other ideas?

I have still haven't had the free time to look at a Procmon trace.

Evan


Top 
 Profile  
Reply with quote  
 Post subject: Re: Why does browsing a network share in Explorer take so lo
 Post Posted: Thu Mar 28, 2013 2:05 pm 
Offline
Site Admin

Joined: Sun Feb 04, 2007 11:44 am
Posts: 6180
Only thing I can think of is that it is due to some difference between that server and the others. It could be the OS, configuration, network card and/or driver, or possibly even a cable. If you could isolate the differences you would eventually find the answer, however it could take a lot of time and/or effort. Let me know if you do ever find out. Scott.


Top 
 Profile  
Reply with quote  
 Post subject: Re: Why does browsing a network share in Explorer take so lo
 Post Posted: Thu Mar 28, 2013 5:19 pm 
Offline

Joined: Wed Mar 18, 2009 12:48 pm
Posts: 405
Location: USA
I will.

I know it isn't a cable issue as it happens with everyone that has access to the share and also a different share on the same partition doesn't have the delay.

Evan


Top 
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 13 posts ] 

Board index » Upgrading and Repairing Forum » Windows OS


Who is online

Users browsing this forum: No registered users and 4 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron